top of page

counterparty-lib update 9.55.1

Release Announcement for counterparty-lib 9.55.1Counterparty experienced roughly 14 hours of downtime on December 2nd, 2016. Counterparty is back up and running thanks to a fix enacted by several leading Counterparty developers. Ruben de Vries will be porting changes from master to develop within the next day or so. Please update to the latest version of counterparty-lib (9.55.1) as soon as possible. The problem that occurred was due to counterparty-lib not properly handling out-of-range integer data in an edge case. To be more specific, a message was broadcast to the network that was either created by a non-counterparty-lib implementation or a hand-constructed Counterparty transaction. The fix enacted by Counterparty development should prevent this from ever happening in the future on any integer data that is embedded in the protocol. This error caused downtime for Counterparty but no rollback will be necessary. The transaction that caused the error was the last to occur before downtime and activity has started once more from the spot of the problem transaction. Thank you for your support of Counterparty. As an open-source project our community is our most valuable resource. If you have any questions please feel free to reach out to us on the #dev channel on Slack. You can also join the conversation via Telegram.

Comments


bottom of page